NV200 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi,

The clunk sounds like a louder version of anti roll bar bushes needing replacement, and does not happen all the time.

Mechanic has checked everything, replaced a cracked engine mount and left shock mount.

He said it could be the driveshaft, has anyone else experienced a similar issue?.
 

·
Registered
Joined
·
3 Posts
I have a similar issue, replaced drop links, lower ball joints, strut mounts, still happens and I’m thinking it could be the anti roll bar bushes potentially. They are located above the subframe for removal annoyingly. I had a look while swapping out the lower ball joints. Other option could be swapping out the wishbone in one hit as this will then at least cover it being any of those bushes.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Thank you, that's interesting, it could be I guess, never realised they were above the subframe.
 

·
Registered
Joined
·
3 Posts
@mrflory, I did find this the other day... knocking on steering column
Yeh I saw that a little while back when mine started doing it. I replaced the lower ball joint and that seemed to improve it which is why I’m clinging to the idea it’s something down that way that’s causing the issue.. It flew through the MOT and he was very thorough and didn’t pick up a single issue. Yeh those anti roll bar bushes are mounted on top of the subframe unfortunately.. I’m thinking of chucking a whole wishbone at it as they’re relatively cheap even for a branded one and seeing what that does and then trying to get at that roll bar bush at the same time.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
Nice, please do let me know how you get on if you do. I'll try to get round to the same some point soon, I'll post my findings soon
 
1 - 7 of 7 Posts
Top