NV200 Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Driving home today in my 2015 NV200 and all of a sudden the van won't accelerate and engine and temperature dash lights come on??!! Seem to drive like in limp mode. Anybody have this issue or can advise? Thank you.
 

·
Registered
Joined
·
218 Posts
If the engine overheat (temperature) light was on it was likely overheating and in limp mode. Usually a person would pull over and let it cool down? That’s assuming it’s actually overheating. Does your rad fan work as it should, is it full of coolant???

Nobody on the internet can tell you why your engine light is on.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
Hello. The engine light stayed on with the temp light. Would not accelerate (no power) but continued going. Able to drive short distance to my home without being stranded. That was yesterday. This morning checked the coolant, radiator is full so is side reservoir. So no leaks and no problem with cooling system I guess. So engine did not overheat I assume. So I turn the key to turn it on to check the tranny fluid and the electric comes on but does not turn over. Won't start. Dead. Maybe it needs tranny fluid but how do I check it if it does not run? Hope the tranny is not toast!! I guess the scanner would check the codes and help start it???
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
It has 103000 miles. I bought this from a dealer about 5 weeks ago. They were supposed to check all the fluids. I do have a 3 month 3000 limited powertrain warranty that comes with it though. That would be helpful if the tranny is toast. Anyway I certainly would not be responsible for previous poor maintenance if that is the issue.
 

·
Registered
Joined
·
218 Posts
If you've got warranty I'd probably use it. You gotta assume everyone's an idiot and didn't properly check the fluids. lol
Engine not starting doesn't normally mean your transmission is toast.
Check your rad fan, does it spin freely. Do you have an accessory belt still? Maybe your belt broke? I've seen them break at around that same mileage on these vans. That'd explain the temp light and dead battery. But normally the battery light would have been on while driving too.
Or maybe you forgot a light on or there's something else that drained the battery overnight? Does rad fan come one when you turn the key on?
 

·
Registered
Joined
·
218 Posts
Try wiggling the shifter, a little or try starting it in neutral instead of park. Does it make any noise when you try to start it, any loud click under the hood? Is there a red (or orange) theft or Key light on the cluster? Does it have an alarm/starter kill by chance?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Try wiggling the shifter, a little or try starting it in neutral instead of park. Does it make any noise when you try to start it, any loud click under the hood? Is there a red (or orange) theft or Key light on the cluster? Does it have an alarm/starter kill by chance?
I don't think it is the battery otherwise the dash lights would not come on. I think the battery is fine. It just does not start. The engine does not turn on. When I get the code reader on Friday maybe it will answer some of these questions. If not or if it is too complicated for my skill ability I will just have to towed to the local service center. The tow would be free under my auto insurance and I have the powertrain warranty so I cannot be buried in a service bill if it is something major. Or maybe it is just something simple..

I wish it was just the a couple of dash lights which was the initial minor problem..LOL.
 

·
Registered
Joined
·
10 Posts
Driving home today in my 2015 NV200 and all of a sudden the van won't accelerate and engine and temperature dash lights come on??!! Seem to drive like in limp mode. Anybody have this issue or can advise? Thank you.
I highly recommend buying an aftermarket heads up display. My 2017 didn't have a temp gauge or volt gauge, and those are really necessary in my opinion. So I bought a heads up display that shows miles per gallon, engine temperature, alternator voltage output, and speed. It cost about $120 from Amazon, but it's totally worth it. I love it.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
Call the dealer you purchased it from. The warranty clock is ticking.
Call the dealer? It is a used vehicle bought as is with a powertrain warranty. In USA there are no lemon laws for used vehicles. You are basically on your own.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #12 ·
I highly recommend buying an aftermarket heads up display. My 2017 didn't have a temp gauge or volt gauge, and those are really necessary in my opinion. So I bought a heads up display that shows miles per gallon, engine temperature, alternator voltage output, and speed. It cost about $120 from Amazon, but it's totally worth it. I love it.
Thanks but that will not solve my problem and get my vehicle running.
 

·
Registered
Joined
·
4 Posts
Call the dealer? It is a used vehicle bought as is with a powertrain warranty. In USA there are no lemon laws for used vehicles. You are basically on your own.
Ok guess I misread your post stating you had 3 month 3000 limited powertrain warranty!
"It has 103000 miles. I bought this from a dealer about 5 weeks ago. They were supposed to check all the fluids. >>I do have a 3 month 3000 limited powertrain warranty<< that comes with it though. That would be helpful if the tranny is toast. Anyway I certainly would not be responsible for previous poor maintenance if that is the issue."
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #14 ·
Ok guess I misread your post stating you had 3 month 3000 limited powertrain warranty!
"It has 103000 miles. I bought this from a dealer about 5 weeks ago. They were supposed to check all the fluids. >>I do have a 3 month 3000 limited powertrain warranty<< that comes with it though. That would be helpful if the tranny is toast. Anyway I certainly would not be responsible for previous poor maintenance if that is the issue."
You stated call the dealer that I bought the vehicle from. I responded NO. Because I bought the vehicle used from a Chrysler Dealership in ILLINOIS. I live in FLORIDA. I will not bring the vehicle to ILLINOIS to service it OBVIOUSLY. The WARRANTY allows me to service it locally where I live in FLORIDA. That is the ANSWER to your question,
 

·
Registered
Joined
·
218 Posts
Good to know, so you're suck figuring this out yourself or find someone who can locally.

Did you check any of the things I mentioned? Err no. How about that obdII deal. I wouldn't expect it to do much other than say your engine was overheated. But hopefully it'll pick up some other codes.
Knowing your engine temp could be handy. If your temp sensor is out to lunch or the wiring shorted out that could cause a problem.
Anywhore, I'll check back later today or on the weekend.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #16 ·
Ok guys. Got my obd scanner. Scanned it. Comes up P1217 Engine Over Temperature. So causes are:

P1217 NISSAN code possible causes

  • Faulty Thermostat
  • Faulty cooling fan motor
  • Cooling fan harness is open or shorted
  • Cooling fan circuit poor electrical connection
  • Engine Control Module (ECM) Program
  • Leaking radiator hose
  • Leaking or clogged radiator
  • Radiator cap
  • Leaking or damage Water pump
I will bring to local dealer to check and repair. Thank you all for your suggestions.
 

·
Registered
Joined
·
218 Posts
Yikes. Any competent independent shop should be able to figure that out and be cheaper than a dealer. I assume you did make sure it still has a belt on it? Stupid question but I asked 3 times now and didn't get an answer lol.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #18 ·
I was waiting for you to ask to me 6x then I would answer. Lol. The belt seems fine not broken or damaged. Many of the independent mechanics near me are crooks and will make it a bigger issue than it is. But rather use the warranty at the service dept at Nissan dealer. Anyway we will see. If it is mainly a coolant or electrical issue and not covered by the warranty then I do not see it as costing me a lot. Regardless we will see.
 

·
Registered
Joined
·
1 Posts
I highly recommend buying an aftermarket heads up display. My 2017 didn't have a temp gauge or volt gauge, and those are really necessary in my opinion. So I bought a heads up display that shows miles per gallon, engine temperature, alternator voltage output, and speed. It cost about $120 from Amazon, but it's totally worth it. I love it.
Please share brand you purchased?
 
1 - 20 of 22 Posts
Top