NV200 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hi people just bout a nissan 1.5 dci 61 plate loving it but need a bit of advice it is making a loud chapping noise from high up in the engine i thought ok will change timing belt all marks lined up so it had not jumped teeth replaced water pump as well at the same time all good job done but no still making this chapping noice now i have bougt tappets and a camshaft to go into it gonna start that tonight gggr belt has to come of again anyway and one have diagram or know the torque settings for the cam bolts please or has anyone had this problem on here and managed to fix it.

help
scot
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
i take it this is just a site for showing pics of your nv200 and talking about how good the colour of it is.
 

·
Registered
Joined
·
34 Posts
i take it this is just a site for showing pics of your nv200 and talking about how good the colour of it is.
Yes and it's also the site where people post problems and don't get answers. Sorry I can't help you, haven't ever seen a diesel Nissan other than rhd drive patrols that were imported here.
 

·
Registered
Joined
·
34 Posts
i take it this is just a site for showing pics of your nv200 and talking about how good the colour of it is.
Yes and it's also the site where people post problems and don't get answers. Sorry I can't help you, haven't ever seen a diesel Nissan other than rhd drive patrols that were imported here.
 
1 - 4 of 4 Posts
Top